View Issue Details

IDProjectCategoryView StatusLast Update
0028106mantisbtadministrationpublic2021-03-30 22:36
Reporterjprandstetter Assigned Todregad  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.25.0 
Target Version2.25.1Fixed in Version2.25.1 
Summary0028106: Error removing project
Description

I get the following error if I remove a project from a user:
https://<mysserver>/mantis/manage_user_proj_add.php
<pre>
APPLICATION ERROR 0000201

Ein Feld wurde für project_id erwartet, aber eine Zeichenkette übergeben.
Bitte benutzen Sie die „Zurück“-Taste Ihres Browsers, um auf die vorhergehende Seite zurückzukehren. Dort können Sie den hier angezeigten Eintrag korrigieren oder eine andere Aktion ausführen. Über das Menü können Sie auch direkt zu einer anderen Aktion wechseln.
<pre>
Btw.: If I remove the user from the project it works fine.

TagsNo tags attached.

Relationships

related to 0028114 resolveddregad Invalid HTML in manage_user_edit_page.php 
related to 0028122 resolveddregad Improve handling of project assignment in manage_user_edit_page.php 

Activities

jprandstetter

jprandstetter

2021-03-24 12:45

reporter  

grafik.png (184,580 bytes)   
grafik.png (184,580 bytes)   
atrol

atrol

2021-03-24 17:47

developer   ~0065282

Regression introduced in Commit MantisBT master d45f1dc3

atrol

atrol

2021-03-24 17:59

developer   ~0065283

@dregad just revert for the moment, or do you have a better solution?

Related Changesets

MantisBT: master d45f1dc3

2020-11-21 18:20:41

dregad

Details Diff
Fix invalid HTML

The form was incorrectly defined in the middle of the table. It is now
wrapping it.
Affected Issues
0028106, 0028114
mod - manage_user_edit_page.php Diff File

MantisBT: master-2.25 bbcd5be2

2021-03-25 12:54:56

dregad

Details Diff
Revert "Fix invalid HTML"

This reverts commit d45f1dc31d85cd31dbf028bb2334c810b35ba107.

The change introduced a regression when removing a project from the
manage user page, because the "Remove" button is generated as an HTML
form (via print_project_user_list -> html_button() functions). Since
forms cannot be nested, the parent form's action (manage_user_proj_add.php)
gets triggered instead of the expected one (manage_user_proj_delete.php).

Fixes 0028106
Affected Issues
0028106
mod - manage_user_edit_page.php Diff File