View Issue Details

IDProjectCategoryView StatusLast Update
0028080mantisbtuipublic2021-03-17 14:27
ReporterLukeWCS Assigned Todregad  
PrioritylowSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.25.0 
Target Version2.25.1Fixed in Version2.25.1 
Summary0028080: Unsightly vertical offset of the "Update Prefs" and "Reset Prefs" buttons.
Description

This offset did not yet exist in 2.24.4, it has only occurred since 2.25.0.

Steps To Reproduce

With Opera or Vivaldi:

  • Click on the username at the top right.
  • "My Account" -> "Preferences"
Additional Information

Tested browser:

  • Opera: ERROR
  • Vivaldi: ERROR
  • Firefox: OK
TagsNo tags attached.

Relationships

related to 0027574 closeddregad Manage users edit page: inconsistent spacing between sections 

Activities

LukeWCS

LukeWCS

2021-03-17 10:47

reporter  

atrol

atrol

2021-03-17 11:25

developer   ~0065253

Suppose this is caused by 0027574
Seems that all Blink based Browsers are affected, e.g. also Google Chrome

LukeWCS

LukeWCS

2021-03-17 13:42

reporter   ~0065254

@atrol

Yes, it seems to affect all Blink based browsers. More tests:

  • IE11: OK
  • Edge (89.0): ERROR
dregad

dregad

2021-03-17 14:24

developer   ~0065255

I confirm the behavior also (Chromium 89.0.4389.90).

This is indeed a regression from 0027574, as @atrol suspected - see commit MantisBT master f65b0cae

The Reset Prefs button is displayed via print_form_button() API, which generates an HTML form including a <fieldset> element that Chrome styles with display: block; (user agent stylesheet), causing the vertical offset. Firefox apparently does not do that.

Considering that this fieldset is not really useful in this context, we might as well get rid of it.

Related Changesets

MantisBT: master f65b0cae

2020-11-21 18:19:08

dregad

Details Diff
Fix markup in account_prefs_inc.php

The sequence of wrapping divs was different from the usual layout,
causing inconsistent spacing when the account preferences section
was displayed on manage_user_edit_page.php.

edit_account_prefs() no longer prints the outer div, letting the parent
page take care of it.

Fixes 0027574
Affected Issues
0027574, 0028080
mod - account_prefs_inc.php Diff File
mod - account_prefs_page.php Diff File
mod - manage_user_edit_page.php Diff File

MantisBT: master-2.25 623c74b6

2021-03-17 14:26:47

dregad

Details Diff
Remove <fieldset> from print_form_button() markup

Fixes 0028080
Affected Issues
0028080
mod - core/print_api.php Diff File