View Issue Details

IDProjectCategoryView StatusLast Update
0009155mantisbttime trackingpublic2020-03-15 15:23
ReporterBlue Ninja Assigned Todregad  
PrioritynormalSeveritytweakReproducibilityN/A
Status closedResolutionfixed 
Product Version1.2.0a1 
Target Version2.24.0Fixed in Version2.24.0 
Summary0009155: Cell coloring for due date indicates "overdue" when not overdue yet.
Description

The cell with the alarm clock icon for issues with a due date is colored red on the day of the due date, as well as any days after that. The red coloring seems more consistent with an overdue warning, rather than a "due today" warning. Perhaps red should be used for overdue itmes (starting the following day), and another color, such as yellow, should indicate that it is due today?

Better yet, perhaps making the colors a config variable might be more flexible.

Tagsdue_date

Relationships

related to 0016869 closeddregad mantisbt Change of due date background color 
related to 0026774 resolveddregad MantisTouch Change of due date background color 
child of 0008942 closedatrol mantisbt due date feature 
child of 0026438 closeddregad mantisbt Allow multiple, customizable due date levels 
child of 0026775 resolveddregad MantisTouch Allow multiple, customizable due date levels 

Activities

jreese

jreese

2008-05-16 07:36

reporter   ~0017851

I agree with this. I would even like to be able to disable the colors altogether.

Blue Ninja

Blue Ninja

2008-05-16 11:58

reporter   ~0017856

If the 3 colors (Not due yet, due today, overdue) are set as variables, and a 4th variable controls whether to colorize at all, then this should be flexible enough for everyone. Perhaps:

$g_due_date_cell_coloring_enabled = ON

$g_due_date_cell_color_assigned = '#cceedd'
$g_due_date_cell_color_today = '#ffffb0'
$g_due_date_cell_color_overdue = '#ffa0a0'

Alternatively, the three states could be assigned as an array, like the status colors:

$g_due_date_cell_colors = array( 'assigned' => '#cceedd',
'today' => '#ffffb0',
'overdue' => '#ffa0a0')

smig1o

smig1o

2008-07-31 07:34

reporter   ~0018954

I dont want to differ between today and overdue. And i want to flash overdue in "due day". This way developer will be noticed that he has last doay to finish issue. It may be changed in future when mail notifications about due dates will be added.
Right now you can turn coloring off by editing css file.

Blue Ninja

Blue Ninja

2008-07-31 11:22

reporter   ~0018958

I think if admins don't want to distinguish "due" with "overdue", they could simply set them both to the same colors, no? I would expect that many people, if not most, distinguish between "due today" and "overdue", as do most calendar/task list applications such as Outlook, Sunbird/Lightning, etc.

dregad

dregad

2019-12-08 12:05

developer   ~0063199

PR https://github.com/mantisbt/mantisbt/pull/1589

Related Changesets

MantisBT: master 1aa2adf8

2020-02-02 11:28:05

dregad

Details Diff
Allow multiple, customizable due date levels

New config option defining due date levels allowing administrators to
customize both the number of levels, and the cutover deadlines. CSS can
be used to define the colors.

Fixes 0026438, 0009155, 0016869
PR https://github.com/mantisbt/mantisbt/pull/1589
Affected Issues
0009155, 0016869, 0026438
mod - bug_update_page.php Diff File
mod - bug_view_inc.php Diff File
mod - config_defaults_inc.php Diff File
mod - core/bug_api.php Diff File
mod - core/columns_api.php Diff File
mod - core/commands/IssueViewPageCommand.php Diff File
mod - css/default.css Diff File
mod - docbook/Admin_Guide/en-US/config/duedate.xml Diff File
mod - lang/strings_english.txt Diff File