View Issue Details

IDProjectCategoryView StatusLast Update
0027991mantisbtfilterspublic2021-03-17 15:34
Reporterprakashs Assigned Todregad  
PriorityhighSeverityminorReproducibilitysometimes
Status closedResolutionunable to reproduce 
Product Version1.3.20 
Summary0027991: Problem with ticket filter functionality post upgrade from version 1.2.19 to 1.3.20
Description

Problem with ticket filter functionality post upgrade from version 1.2.19 to 1.3.20.
Cleared browser's cookies, caches, history, site settings but this issue got partially resolved. Whenever we try to switch projects after applying a particular filter then we get the following error:

"Argument 1 passed to filter_ensure_valid_filter() must be of the type array, null given, called in .../core/filter_api.php on line 859 and defined' in '.../core/filter_api.php' line 482"

Steps To Reproduce
  1. Login to http://mantisoup.oup.com/mantisbt/login_page.php?
  2. go to "view issues".
  3. Changed something in the filters
  4. Press "Apply Filte".
  5. Switch the project from top right corner dropdown.
TagsNo tags attached.

Activities

prakashs

prakashs

2021-02-24 11:42

reporter  

image.png (2,712 bytes)   
image.png (2,712 bytes)   
dregad

dregad

2021-02-24 13:03

developer   ~0065152

Unable to reproduce; maybe specific tothe filter you're using, but as you're not providing any details, I can't really help.

And as mentioned previously note that 1.3.x is end-of-life and even if there were a bug it would not be fixed. Please upgrade to latest 2.x version (2.24.4 as of this writing).

prakashs

prakashs

2021-03-05 08:04

reporter   ~0065179

We are still facing this issue in version 1.3.20. Please suggest.

dregad

dregad

2021-03-05 11:23

developer   ~0065180

There is really no point in reopening the issue, if you're not going to provide any information that would allow problem reproduction.