View Issue Details

IDProjectCategoryView StatusLast Update
0027907mantisbtbugtrackerpublic2021-02-20 12:19
ReporterTarkenaut Assigned Toatrol  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionno change required 
Summary0027907: Status Colors all Black
Description

Fresh-ish installation with very little configuration. All of the status colors appear to be black. Tried modifying the custom status string and enums to no avail. Tried clearing browser cache, rebooting web server, and even a second machine. Screenshot attached.

Additional Information

MantisBT Version 2.24.4
Schema Version 210
PHP Version 7.3.19
Database Driver mysqli
Database Version, Description 8.0.21, 8.0.21

TagsNo tags attached.

Relationships

related to 0024189 closedcproensa Status color squares become black 

Activities

Tarkenaut

Tarkenaut

2021-01-23 18:14

reporter  

Capture.PNG (19,359 bytes)   
Capture.PNG (19,359 bytes)   
atrol

atrol

2021-01-24 06:28

developer   ~0065025

@Tarkenaut this should be fixed since 2.22.0, see 0024189

Please provide detailed step by step instructions to reproduce the issue.
The additional information listed below may also be useful:

  • Exact version of MantisBT, Web server, Browser and Operating System
  • Relevant customizations (e.g. changes in config_inc.php, etc)
  • Installed plugins or custom functions ?
  • Was the MantisBT source code modified in any way ?
Tarkenaut

Tarkenaut

2021-01-24 17:47

reporter   ~0065026

Last edited: 2021-01-24 17:47

Hi Atrol,

Exact version of MantisBT, Web server, Browser and Operating System

  • See above in "Additional Information". Running on SMP Debian 4.19.160-2 (2020-11-28) w/ Apache Web Server. I use both Google Chrome and Edge. The problem exists on both. Cache is cleared at the very least, daily.

Relevant customizations (e.g. changes in config_inc.php, etc)
-config.inc only includes database and email settings. I've attached the workflow config dump below for you. The two highlighted rows were applied after the problem started as an attempted fix.

Installed plugins or custom functions ?

  • Nope!

Was the MantisBT source code modified in any way ?

  • Nope!

I have been working with MantisBT for over 10 years. First time I hit a stumbling block with this. This is a new web project.

Tarkenaut

Tarkenaut

2021-01-24 17:50

reporter   ~0065027

And as far as "Steps to Reproduce"... the problem is static across all projects and statuses.

dregad

dregad

2021-01-25 11:27

developer   ~0065030

And as far as "Steps to Reproduce"... the problem is static across all projects and statuses.

... and unfortunately not reproducible on my end (and apparently not for your other projects either), so it's probably something specific to your environment.

Maybe something is caching files between your browser and your web server (e.g. a proxy) ?

Tarkenaut

Tarkenaut

2021-01-25 13:30

reporter   ~0065031

Tonight I'll do a fresh install and copy over the config and see what happens. If I'm still getting it, we'll go from there.

atrol

atrol

2021-02-05 03:50

developer   ~0065070

@Tarkenaut did you succeed in reproducing the issue?

atrol

atrol

2021-02-05 03:56

developer   ~0065072

Last edited: 2021-02-05 03:57

Looked at the attached xlsx.
The issue might be caused by missing color for testing in status_colors setting.
No time at the moment to check it myself.

atrol

atrol

2021-02-20 12:19

developer   ~0065143

Tarkenaut,

You did not provide feedback; I am therefore resolving this issue as "no change required".

Feel free to reopen the issue at a later time and provide the requested information.