View Issue Details

IDProjectCategoryView StatusLast Update
0027595mantisbtbugtrackerpublic2020-12-06 08:04
Reporterchadmiss Assigned Todregad  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionduplicate 
Product Version2.24.1 
Summary0027595: invalid selected default project leads to infinite redirecting loop, when bug_report_page is requested
Description

For some occasions when the default project for a user is invalid (eg they had access to it, set it as default project and then lost access) and they are trying to report a bug while "all projects" is selected. the bug report page runs into an redirecting loop.

this can also happen, when an admin changes the user's prefs since in the list for default projects all projects are listed (maybe those where the admin has access?). there can easily be an invalid project selected

tested in 2.24.1 and 2.24.0

questionable lines in the code for teh infinite loop:

bug_report_page.php lines 140 - 150

if( ( ALL_PROJECTS == $t_project_id || project_exists( $t_project_id ) )
        && $t_project_id != $t_current_project
        && project_enabled( $t_project_id ) ) {
        helper_set_current_project( $t_project_id );
        # Reloading the page is required so that the project browser
        # reflects the new current project
        print_header_redirect( $_SERVER['REQUEST_URI'], true, false, true );
    }
TagsNo tags attached.

Relationships

duplicate of 0026988 resolveddregad issue report TOO_MANY_REDIRECTS 

Activities

chadmiss

chadmiss

2020-11-26 08:07

reporter   ~0064706

sorry, pasted code without being aware of markup syntax

dregad

dregad

2020-11-26 13:07

developer   ~0064707

Duplicate of 0026988