View Issue Details

IDProjectCategoryView StatusLast Update
0026995mantisbtemailpublic2020-06-13 06:14
Reportermaturbet Assigned Todregad  
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionno change required 
PlatformGEODE 2.24.1OSdebianOS Version10.4
Product Version2.23.0 
Summary0026995: "In-Reply-To" field malformation in the email header
Description

After MantisBT upgrade to 2.41.1 (from 2.18) this field has changed :

Before :
In-Reply-To: <5db478f8f0f50bb69887094ebbb7a6d8@geode.asso-cocktail.fr>

After (furthermore in 2 lines) :
In-Reply-To: =?us-ascii?Q?<5db478f8f0f50bb69887094ebbb7a6d8@geode.asso-co?=
=?us-ascii?Q?cktail.fr>?=

Have I made something wrong ?

Additional Information

This field is useful to display emails per conversation

TagsNo tags attached.

Activities

dregad

dregad

2020-05-29 07:51

developer   ~0064041

Last edited: 2020-05-29 07:52

View 2 revisions

I would not qualify this as malformed - it is valid RFC2047 Q-encoding , which is folded (see RFC 822 section 3.1.1) to avoid header corruption when the lines are longer than 63 chars.

If your software is choking on that, then it means it is not standards-compliant.

The change in behavior was introduced in PHPMailer 6.1 (see https://github.com/PHPMailer/PHPMailer/pull/1840), MantisBT release 2.23.0.

maturbet

maturbet

2020-05-29 09:52

reporter   ~0064046

Okay, I learned something today !

I'm not really surprised that Outlook isn't standards-compliant, but more about Zimbra and Thunderbird.
I might have something to do on my end...

dregad

dregad

2020-05-29 10:14

developer   ~0064048

TBH, I'm not an expert, but PHPMailer's maintainer is so I'm pretty sure he fully validated that before merging the change.

BTW You have not explained what the actual problem is, on the mail client side.

maturbet

maturbet

2020-05-29 10:19

reporter   ~0064049

Forgive me for not being explicit in the ticket.
The mails of the same ticket were grouped together in conversation in the mail client and are no longer grouped together since the upgrade we did.

Issue History

Date Modified Username Field Change
2020-05-29 06:26 maturbet New Issue
2020-05-29 07:51 dregad Assigned To => dregad
2020-05-29 07:51 dregad Status new => resolved
2020-05-29 07:51 dregad Resolution open => no change required
2020-05-29 07:51 dregad Note Added: 0064041
2020-05-29 07:52 dregad Product Version 2.24.1 => 2.23.0
2020-05-29 07:52 dregad Note Edited: 0064041 View Revisions
2020-05-29 09:52 maturbet Note Added: 0064046
2020-05-29 10:14 dregad Note Added: 0064048
2020-05-29 10:19 maturbet Note Added: 0064049
2020-06-13 06:14 atrol Status resolved => closed