View Issue Details

IDProjectCategoryView StatusLast Update
0026687mantisbtbugtrackerpublic2020-03-15 15:23
Reporterdregad Assigned Todregad  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Target Version2.24.0Fixed in Version2.24.0 
Summary0026687: Required fields when reporting an issue, should also be when updating it
Description

By default, Category, Summary and Description fields are mandatory when reporting an issue.

This is indicated by the "*" and (since 0022310), enforced by the HTML required attribute (see also 0026686).

For consistency, the same behavior should apply when updating an issue as well, without having to reach the necessary field empty error (application error 11).

TagsNo tags attached.

Relationships

related to 0022310 closedcommunity Use HTML5 "required" attribute for required form fields 
related to 0026686 closeddregad Make category on bug_report_page a required field when $g_allow_no_category = OFF; 

Activities

Related Changesets

MantisBT: master 29bdffac

2020-02-10 09:58:01

dregad

Details Diff
Required fields consistency

Fields required when reporting issue should also be when updating it.

Fixes 0026687
Affected Issues
0026687
mod - bug_update_page.php Diff File