View Issue Details

IDProjectCategoryView StatusLast Update
0026294mantisbtuipublic2019-12-09 04:31
Reportercproensa Assigned Tocproensa  
PriorityhighSeveritymajorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version2.23.0 
Target Version2.23.0Fixed in Version2.23.0 
Summary0026294: Attachments without note text are not displayed
Description

When files are attached without a note text, are not displayed to some users

They are removed by this code:
https://github.com/mantisbt/mantisbt/blob/1d349c5ea89112264a4315284c94479ce0ae553a/core/bugnote_api.php#L492-L496

If having:
$g_time_tracking_view_threshold = DEVELOPER;

a reporter user can't see this kind of attachments.

Additional Information

Reproducible with this issue, having two attachments, when accesed as unlogged user.

TagsNo tags attached.

Relationships

related to 0022635 closedvboctor Empty notes with time tracking show as empty notes for users that can't view time tracking 
related to 0026082 closedvboctor Create a place holder note when submitting attachments without text 

Activities

cproensa

cproensa

2019-10-22 04:23

developer   ~0063012

Selección_432.png (227 bytes)   
Selección_432.png (227 bytes)   
cproensa

cproensa

2019-10-22 04:24

developer   ~0063013

test

Selección_432-2.png (227 bytes)   
Selección_432-2.png (227 bytes)   
cproensa

cproensa

2019-10-27 17:46

developer   ~0063021

PR: https://github.com/mantisbt/mantisbt/pull/1576

atrol

atrol

2019-11-01 08:55

developer   ~0063047

Didn't have a deeper look, but I assume this is related / caused by 0026082

Related Changesets

MantisBT: master 645d1c67

2019-10-25 11:47:52

cproensa


Committer: vboctor Details Diff
Revert "Don’t show completely empty notes"

After implementing the linking of notes and attachments, attachments
linked to a note without text are not displayed to some users becasue of
the time tracking logic, even if that functionality is not enabled.

This reverts commit 1ed44a96567e23da446f2678a717360f678d2d00.

Fixes: 0026294
Affected Issues
0026294
mod - core/bugnote_api.php Diff File