View Issue Details

IDProjectCategoryView StatusLast Update
0025951mantisbtplug-inspublic2020-08-03 12:59
Reporterdregad Assigned Todregad  
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Target Version2.22.0Fixed in Version2.22.0 
Summary0025951: MantisGraph: update Chart.js library to v2.8.0
Description

Chart.js 2.8.0 was released in March 2019.

At the same time, the colorschemes plugin should also be updated as v0.4.0 was released on 31-May-2019.

TagsNo tags attached.

Relationships

related to 0025488 closedatrol Update Chart.js to 2.7.3 
related to 0025523 closeddregad MantisGraph: improve handling of colors in Pie charts 
related to 0025952 closeddregad MantisGraph: define Chart.js-related constants in the plugin 
related to 0027124 resolveddregad MantisGraph: update Chart.js library to v2.9.3 

Activities

dregad

dregad

2019-08-02 13:56

developer   ~0062489

Currently the plugin uses 2 distinct CDN sources for the Chart.js (CloudFlare) and the colorschemes plugin (jsDelivr).

Standardizing on a single CDN would facilitate future maintenance.

dregad

dregad

2019-08-02 14:07

developer   ~0062491

PR https://github.com/mantisbt/mantisbt/pull/1533

Related Changesets

MantisBT: master 2e1d1ca1

2019-08-01 06:59:44

dregad

Details Diff
Use jsDelivr CDN for all MantisGraph javascripts

Standardize on a single CDN source. jsDeliver was selected because the
colorschemes Chart.js plugin is not available on CloudFlare.

Fixes 0025951 (see 0025951:0062489)
Affected Issues
0025951
mod - plugins/MantisGraph/MantisGraph.php Diff File

MantisBT: master 0dda9fa1

2019-08-03 09:54:11

dregad

Details Diff
Update Chart.js library to v2.8.0

Fixes 0025951
Affected Issues
0025951
mod - library/README.md Diff File
mod - plugins/MantisGraph/MantisGraph.php Diff File
rm - plugins/MantisGraph/files/Chart-2.7.3.min.js Diff File
add - plugins/MantisGraph/files/Chart-2.8.0.min.js Diff File
rm - plugins/MantisGraph/files/Chart.bundle-2.7.3.min.js Diff File
add - plugins/MantisGraph/files/Chart.bundle-2.8.0.min.js Diff File

MantisBT: master c46d88a0

2019-08-03 09:55:48

dregad

Details Diff
Update colorschemes Chart.js plugin to v0.4.0

Fixes 0025951
Affected Issues
0025951
mod - library/README.md Diff File
mod - plugins/MantisGraph/MantisGraph.php Diff File
add - plugins/MantisGraph/files/chartjs-plugin-colorschemes-0.4.0.min.js Diff File
rm - plugins/MantisGraph/files/chartjs-plugin-colorschemes.min.js Diff File