View Issue Details

IDProjectCategoryView StatusLast Update
0025682mantisbtuipublic2019-04-21 02:53
Reporter123 Assigned Tocommunity  
PrioritynormalSeveritytweakReproducibilityhave not tried
Status closedResolutionfixed 
Target Version2.21.0Fixed in Version2.21.0 
Summary0025682: Show Invite button for users with manage users access level, not just administrators
Description

I propose to change the condition for displaying the button "Invite user" with
current_user_is_administrator ()
on
access_has_global_level (config_get ('manage_user_threshold'))

Since users with the manage_user_threshold access level have the right to manage users, why not simplify their access to this function?

TagsNo tags attached.

Activities

123

123

2019-04-09 02:26

reporter   ~0061867

PR https://github.com/mantisbt/mantisbt/pull/1500

123

123

2019-04-09 02:27

reporter   ~0061868

In part, this was discussed in 0021223

Related Changesets

MantisBT: master 0d6256d2

2019-04-13 02:24:43

123


Committer: vboctor Details Diff
Fix permissions to invite button

We will show the button to everyone who has the rights to manage user accounts.

Fixes 0025682
Affected Issues
0025682
mod - core/layout_api.php Diff File