View Issue Details

IDProjectCategoryView StatusLast Update
0025632mantisbtuipublic2019-04-05 17:14
Reporterjingshaochen Assigned Todregad  
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionduplicate 
Summary0025632: Status color boxes should not have background css set
Description

Bug status square has status_config.php set its background-color. This somehow added a pixel extra to the sides of the fontawesome icon square and makes it not smooth. visible to eye when users use a strong color.

See attached screen capture for with and without background color.

I will suggest to remove the background-color style.

TagsNo tags attached.

Relationships

duplicate of 0023550 closeddregad Modification to status colors css 

Activities

jingshaochen

jingshaochen

2019-03-21 17:10

reporter  

without background color.png (7,084 bytes)   
without background color.png (7,084 bytes)   
with background color.png (6,993 bytes)   
with background color.png (6,993 bytes)   
dregad

dregad

2019-03-22 07:15

developer   ~0061735

Last edited: 2019-03-22 08:22

I can confirm the behavior, but fixing it is not as simple as removing the background color per your suggestion.

The problem is that these classes are not only used for the status boxes (i.e. to paint the fontawesome icon), but also in various places where changing the background color is the intended behavior (e.g. bug_update_page, and the deprecated sponsorship pages). They could also be referenced by 3rd party plugins.

dregad

dregad

2019-03-22 08:32

developer   ~0061736

PR https://github.com/mantisbt/mantisbt/pull/1484

@jingshaochen please test and let me know your feedback.

jingshaochen

jingshaochen

2019-03-22 11:50

reporter   ~0061739

As a user, I feel having to define fg and bg colors in two config variables is confusing. Where is the bg color used and do we really need it? If it is used in bug_update_page, can we not use the bg color? I think the reason for the color is to give a user visual distinguish when multiple items are put together. In update page, there is only one status at display. The color's purpose is not served.

jingshaochen

jingshaochen

2019-03-22 12:01

reporter   ~0061741

Another suggestion is to use the same fg color square int the bug update page. Provide the same visual as other views is much easier for a user to recognize.