View Issue Details

IDProjectCategoryView StatusLast Update
0025368mantisbtadministrationpublic2019-11-19 07:40
Reportercproensa Assigned Tocproensa  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version2.20.0 
Target Version2.20.0Fixed in Version2.20.0 
Summary0025368: Manage project, copy from/to forms are easy to click accidentally and don't ask for confirmation
Description

The forms to copy versions, custom fields, users, etc from another project, or into another project, don't ask for user confirmation.
The placement of these forms are very close to the standard management areas, so there is a risk for the user to accidentally click those.

Fixing the mess after one of those accidents, for example users, is difficult because usually there's a lot of items copied.

TagsNo tags attached.

Relationships

related to 0026367 closedcproensa Use empty value as default project in "manage project" subproject section 

Activities

Related Changesets

MantisBT: master f37dffa5

2019-01-23 06:28:38

cproensa


Committer: dregad Details Diff
Manage project page, safe copy from/to forms

In manage project edit page, make the forms in each section for copying
items to/from other projects to not have an initial project as selected,
and make the selection as required.
This avoid to accidentally use this actions, without having made an
explicit selection in them.

Fixes: 0025368
Affected Issues
0025368
mod - manage_proj_edit_page.php Diff File