View Issue Details

IDProjectCategoryView StatusLast Update
0024239mantisbtemailpublic2018-04-29 19:21
Reporterj_schultz Assigned Toatrol  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version2.12.0 
Target Version2.13.2Fixed in Version2.13.2 
Summary0024239: Inconsistent realname display
Description

I have noticed that on this bugtracker right here, I cannot see real names of any users. For example, if I go to https://www.mantisbt.org/bugs/view_user_page.php?id=11111 I do not see @atrol's real name.
However, when I receive an email notification, I do see his real name there. From what I understand, I shouldn't be able to see the real name there, because it is also hidden everywhere else.

TagsNo tags attached.

Relationships

related to 0023375 closedvboctor It is hard to @ mention users when show realnames is enabled 

Activities

atrol

atrol

2018-04-09 15:16

developer   ~0059495

Thanks @j_schultz for letting us know.

I disabled $g_show_realname for the moment.

Can you confirm that you don't see my real name in the email notification for this change?

j_schultz

j_schultz

2018-04-09 15:20

reporter   ~0059496

The mail I received for the mention only contained your username, yes.

atrol

atrol

2018-04-09 16:48

developer   ~0059497

PR https://github.com/mantisbt/mantisbt/pull/1330

Related Changesets

MantisBT: master-2.13 8fd2701b

2018-04-09 16:34:14

atrol

Details Diff
Send always usernames in email notifications

Don't send realnames if $g_show_realname = ON;

This is a quick workaround as a clean solution needs some redesign.

At the moment $g_show_user_realname_threshold is considered based
on the current user.
This is wrong, as the option must be considered based on the
recipient of the notification.

Fixes 0024239
Affected Issues
0024239
mod - core/email_api.php Diff File