View Issue Details

IDProjectCategoryView StatusLast Update
0024090mantisbtuipublic2018-07-09 16:52
Reporterclan_destina Assigned Tovboctor  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Target Version2.12.1Fixed in Version2.12.1 
Summary0024090: Username (Realnames) format not showing on timeline (my_view_page)
Description

If the variable: $g_show_realname = ON

The realname on the timeline should be displayed: Username (RealName) instead of just the RealName

TagsNo tags attached.

Relationships

related to 0024087 closedatrol $g_show_realname problem on 2.12.0 
related to 0024161 closedatrol Wrong color of username in timeline 
related to 0024069 closedvboctor Show realname not working 
related to 0024167 closedatrol History entries display realname instead of username 
related to 0024077 closedvboctor Hyperlink usernames in timeline to user page 

Activities

atrol

atrol

2018-03-09 10:26

developer   ~0059143

Does adding the following line to file config_inc.php fix the issue?

$g_show_user_realname_threshold = ANYBODY;
fman

fman

2018-03-10 05:20

reporter   ~0059148

I'm checking the code because I'm not able to display realnames on combo, and seems that refactoring in 2.12.0 has introduced this problem
probably with new config option, but also there is a related error on
function user_get_expanded_name_from_row(), because realname is not used

If you want I will open a new issue related to this.

Anyway IMHO, the choice of 'username (realname)' at least on combos has to be configurable and not the default as seems to be on 2.12.0

fman

fman

2018-03-10 05:24

reporter   ~0059149

Common error write before test => the error on user_get_expanded_name_from_row() is that return value is:
realname (username) and not as described on function header:

  • Get display name in format "username (realname)"
fman

fman

2018-03-10 05:25

reporter   ~0059150

I've added $g_show_user_realname_threshold = VIEWER;

clan_destina

clan_destina

2018-03-10 17:34

reporter   ~0059160

$g_show_user_realname_threshold = ANYBODY;

The problem persists

vboctor

vboctor

2018-03-12 21:52

manager   ~0059190

Last edited: 2018-03-13 05:25

I have submitted a PR that changes timeline to use the standard API for displaying usernames
PR: https://github.com/mantisbt/mantisbt/pull/1317

This means:

  • Always display usernames
  • Hyperlink to user page which has more info about the user.
  • Have the user realname as a bubble.
  • Only show realname when $g_show_realname = ON and logged in user has access level >= $g_show_user_realname_threshold

Related Changesets

MantisBT: master-2.12 02d8b8af

2018-03-12 21:47:50

vboctor

Details Diff
Use standard API to display username in timeline

Fixes 0024090
Affected Issues
0024090
mod - core/classes/IssueAssignedTimelineEvent.class.php Diff File
mod - core/classes/IssueCreatedTimelineEvent.class.php Diff File
mod - core/classes/IssueMonitorTimelineEvent.class.php Diff File
mod - core/classes/IssueNoteCreatedTimelineEvent.class.php Diff File
mod - core/classes/IssueStatusChangeTimelineEvent.class.php Diff File
mod - core/classes/IssueTagTimelineEvent.class.php Diff File