View Issue Details

IDProjectCategoryView StatusLast Update
0024043mantisbtldappublic2018-03-04 00:36
Reporterraspopov Assigned Tocommunity  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version2.11.1 
Target Version2.12.0Fixed in Version2.12.0 
Summary0024043: $g_ldap_realname_field generates WARNING: field 'givenName' does not exist.
Description

A LDAP attribute specified in $g_ldap_realname_field option in the well-know form (i.e. 'displayName', 'givenName' etc.) doesn't work, seems only lower-cased supported.

Steps To Reproduce
  1. Set option: $g_ldap_realname_field = 'givenName';
  2. Make sure LDAP logging is on.
  3. Login to Mantis.
TagsNo tags attached.

Activities

raspopov

raspopov

2018-02-26 11:32

reporter   ~0059042

Fixed in PR: https://github.com/mantisbt/mantisbt/pull/1306

Related Changesets

MantisBT: master 34978af2

2018-02-27 20:04:56

raspopov


Committer: vboctor Details Diff
Fixed case-sensitive LDAP attributes names

A ldap_get_entries() function returns attribute names as lowercase keys so next call
of array_key_exists() fails because of it performs a case-sensitive comparison.
For example if a $g_ldap_realname_field option is set to 'givenName'
(a well-known LDAP attribute display name) then it finds nothing.

Fixes 0024043
Affected Issues
0024043
mod - core/ldap_api.php Diff File