View Issue Details

IDProjectCategoryView StatusLast Update
0023942mantisbtbugtrackerpublic2020-12-07 12:02
Reporterdregad Assigned Todregad  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version2.0.0 
Target Version2.11.0Fixed in Version2.11.0 
Summary0023942: Remove deprecated "errcontext" parameter from standard error handler
Description

The $errcontext parameter for the error handler function has been deprecated in PHP 7.2 [1][2], and PHP documentation says that Relying on it is highly discouraged [3]

We currently use this parameter to display some of the local variables (excluding objects) when an error is triggered and $g_show_detailed_errors = ON, but the output is broken and difficult to read since 2.x was released.

Considering the deprecation notice, it does not make sense to fix the layout now since the raw data will no longer be available in the next major PHP release.

This issue covers the change in MantisBT error handler's signature, as well as removal of all code dedicated to printing Context information on the detailed error page.

TagsNo tags attached.

Relationships

related to 0027701 resolvedatrol System notice in lang_error_handler 
related to 0027703 resolvedatrol Error handlers use deprecated context parameter 
related to 0023943 closeddregad Improve detailed error page layout 
related to 0023944 closeddregad The stack trace on detailed error page should not include the error handler itself 

Activities

Related Changesets

MantisBT: master 276c0310

2018-02-06 17:35:52

dregad


Committer: vboctor Details Diff
Remove error handler's "errcontext" parameter

The $errcontext parameter for the error handler function has been
deprecated in PHP 7.2.

We currently use this parameter to display some of the local variables
when an error is triggered and $g_show_detailed_errors = ON, but the
output is broken and difficult to read since 2.x was released.

Considering the deprecation notice, it does not make sense to fix the
layout now since the raw data will no longer be available in the next
major PHP release.

This commit changes the error handler's signature, and removes all code
dedicated to printing Context information on the detailed error page.

Fixes 0023942
Affected Issues
0023942
mod - core/error_api.php Diff File