View Issue Details

IDProjectCategoryView StatusLast Update
0023926mantisbtuipublic2018-02-06 21:17
Reporterdregad Assigned Todregad  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version2.0.0 
Target Version2.11.0Fixed in Version2.11.0 
Summary0023926: Footer displayed under sidebar on error page when $g_show_detailed_errors = ON
Description

See attached screenshot

TagsNo tags attached.

Relationships

related to 0020240 closedsyncguru Footer issue: problem + solution 

Activities

dregad

dregad

2018-02-03 07:53

developer  

Selection_001.png (12,675 bytes)   
Selection_001.png (12,675 bytes)   
dregad

dregad

2018-02-03 07:55

developer   ~0058728

Caused by an extra <div> in error_print_stack_trace().

dregad

dregad

2018-02-06 17:32

developer   ~0058785

PR https://github.com/mantisbt/mantisbt/pull/1286

Related Changesets

MantisBT: master a02b5dcb

2018-02-03 06:03:36

dregad


Committer: vboctor Details Diff
Fix HTML in error page when $g_show_detailed_errors = ON

- Added missing </div> causing footer to be hidden behind the sidebar
- Removed unnecessary <p> tags containing <div> and/or <table> tags
- Added a few newlines to make generated HTML easier to read

Fixes 0023926
Affected Issues
0023926
mod - core/error_api.php Diff File