View Issue Details

IDProjectCategoryView StatusLast Update
0023838mantisbtapi restpublic2019-05-23 02:42
Reportervboctor Assigned Tovboctor  
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version2.10.0 
Target Version2.11.0Fixed in Version2.11.0 
Summary0023838: Create user via REST API
Description

Add support for creating users via REST API and using the UserCreateCommand.

TagsNo tags attached.

Relationships

related to 0023837 closedvboctor Implement UserCreateCommand to create users 
related to 0023900 closedvboctor Unable to update user access level, due to check on 'Realname' returning KO (APPLICATION ERROR #807) 
related to 0025782 new User Management API 

Activities

Related Changesets

MantisBT: master 3f29dcc4

2018-01-13 17:23:00

vboctor

Details Diff
Support creating users via REST API

Fixes 0023838
Affected Issues
0023838
mod - api/rest/restcore/users_rest.php Diff File
mod - core/commands/UserCreateCommand.php Diff File
mod - core/email_api.php Diff File
mod - core/user_api.php Diff File