View Issue Details

IDProjectCategoryView StatusLast Update
0023639mantisbtcode cleanuppublic2018-02-01 03:58
Reporteratrol Assigned Toatrol  
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Target Version2.9.0Fixed in Version2.9.0 
Summary0023639: Unneeded code for non supported old PHP versions
Description

We require PHP >= 5.5 at the moment, but there is still code that treats older PHP versions.

TagsNo tags attached.

Relationships

related to 0023707 closedatrol Version 2.9.0 broke the Image view/download of attachments 
related to 0023877 closeddregad Mantis graphs not displaying 

Activities

Related Changesets

MantisBT: master 1187d005

2017-11-15 08:06:46

atrol

Details Diff
Remove travis web server setup for old PHP versions

Issue 0023639
Affected Issues
0023639
mod - scripts/travis_before_script.sh Diff File

MantisBT: master 5f6292fb

2017-11-15 08:23:45

atrol

Details Diff
Remove finfo class existence checks

As of PHP >= 5.3.0 finfo class is available [1] and enabled by default [2]

[1] http://www.php.net/manual/en/class.finfo.php
[2] http://www.php.net/manual/en/fileinfo.installation.php

Removed all runtime checks but kept them in install/check to have an easy way to find the case where someone disabled the extension.

Issue 0023639
Affected Issues
0023639
mod - core/file_api.php Diff File
mod - core/utility_api.php Diff File

MantisBT: master 1254f0dd

2017-11-15 08:45:37

atrol

Details Diff
Remove check for PHP version < 5.3.7

Issue 0023639
Affected Issues
0023639
mod - core/crypto_api.php Diff File