View Issue Details

IDProjectCategoryView StatusLast Update
0023264mantisbtapi restpublic2017-10-08 23:52
Reporterelmarculino Assigned Tocommunity  
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version2.5.1 
Target Version2.7.0Fixed in Version2.7.0 
Summary0023264: Custom fields not been saved when adding issue through the Rest API
Description

When I try to add an issue through the Rest API, I get an '500 Internal Server Error', the issue is added to the database but not the custom fields.
If I try to add an invalid format of the custom fields item in the json, an I get an error informing this. So, when the json is rigth the above error ocurrs.

Steps To Reproduce

Add and issue with custom field through the Rest API

TagsNo tags attached.

Activities

Related Changesets

MantisBT: master a1b8718b

2017-09-28 23:23:05

elmarculino


Committer: vboctor Details Diff
Fix custom field handling in REST API

Fix the custom field handling when creating issues via REST APIs.

Fixes 0023264
Affected Issues
0023264
mod - api/soap/mc_issue_api.php Diff File