View Issue Details

IDProjectCategoryView StatusLast Update
0023251mantisbttimelinepublic2017-10-09 03:05
Reportercproensa Assigned Tocproensa  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version2.6.0 
Target Version2.7.0Fixed in Version2.7.0 
Summary0023251: Timeline in view user page resets the user id after dates navigation
Description

Timeline in view_user_page.php resets the queried user after navigating the dates.

This casues that viewing user page, eg: view_user_page.php?id=2184
After navigation, the 'id' parameter is lost and it points to, eg: view_user_page.php?days=35 loading the page for current user instead
The correct link is view_user_page.php?id=2184&days=35

TagsNo tags attached.

Relationships

has duplicate 0023415 closedatrol view_user_page: an unintended user change when press "Prev" button. 

Activities

Related Changesets

MantisBT: master fc771e16

2017-08-21 13:28:58

cproensa


Committer: dregad Details Diff
Timeline preserve parent script parameters

Correctly preserve parent script parameters for navigation.

Fixes: 0023251
Affected Issues
0023251
mod - core/timeline_inc.php Diff File