View Issue Details

IDProjectCategoryView StatusLast Update
0022926mantisbtcustom fieldspublic2017-06-04 14:58
Reporterdarias.soa Assigned Tovboctor  
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version2.4.1 
Target Version2.4.2Fixed in Version2.4.2 
Summary0022926: Custom Fields - Date: Field does not show date (view.php), shows other text
Description

After updating mantis to 2.4.1, custom fields of type: date do not display their data correctly.

Where I expect to see 2017-02-28 I instead see 1488261600.
Where I expect to see 2017-03-03 I instead see 1488520800.

(Updated two different installations, one originally 1.3.1, and one originally 2.1.0),

Additional Information

I recently updated two of my Mantis instances to newer versions:
1.3.1 -> 2.3.1
2.1.0 -> 2.3.1

I encountered an issue where any project that had a custom field of type: Date, would show the Due Date field in the "Report Issue (bug_report_page.php)" or "Update Issue (bug_update_page.php)" pages but not allow for any data to be input. Viewing an issue would again, show the field, but not show any data at all (view.php). I believe this was addressed in 0022663, 0022758, while there are still open issues listed in 0008957 and 0021873 for this.

I decided to then move to 2.4.1 to see if this was resolved, and I encountered the issue as described above.

Is this a known / addressed issue, planned for solution in 2.5.0 as may be indicated in some of those tickets, or is this a new issue?

TagsNo tags attached.

Relationships

related to 0022428 closedvboctor CSV and Excel exports with markdown on 
related to 0022937 closedvboctor Custom fields of type Email are not properly displayed 
related to 0022950 closedvboctor Custom Fields of Type Text showing Link (Url) as Text only 

Activities

darias.soa

darias.soa

2017-05-24 15:59

reporter   ~0056959

note: this appears to not be an issue in 2.3.3, I just updated my mantis installations to that version and the date appears to display correctly.

TomR

TomR

2017-05-24 17:53

reporter   ~0056960

Note an issue in 2.4.0.

Due to changes in core/custom_field_api.php

aavagyan

aavagyan

2017-05-25 03:56

reporter   ~0056962

I think this is rather urgent because custom fields of date type basically not working.

atrol

atrol

2017-05-25 06:04

developer   ~0056963

@vboctor
I had a short look at it.
I confirm this is a regression introduced in 2.4.1.

vboctor

vboctor

2017-05-25 23:33

manager   ~0056968

PR: https://github.com/mantisbt/mantisbt/pull/1115

Related Changesets

MantisBT: master-2.4 82df9821

2017-05-25 23:31:23

vboctor

Details Diff
Fix date custom field formatting

Fixes 0022926
Affected Issues
0022926
mod - core/custom_field_api.php Diff File