View Issue Details

IDProjectCategoryView StatusLast Update
0022842mantisbtcode cleanuppublic2017-10-28 19:08
Reporterdregad Assigned Todregad  
PrioritynormalSeveritytweakReproducibilityN/A
Status closedResolutionfixed 
Target Version2.8.0Fixed in Version2.8.0 
Summary0022842: Remove php_version_at_least() function from PHP API
Description

The php_version_at_least() function was added back in 2002 (see MantisBT master 18d3e4b5), before the availability of standard version_compare() function (new in PHP 4.1)

TagsNo tags attached.

Activities

There are no notes attached to this issue.

Related Changesets

MantisBT: master e78e7187

2017-05-07 04:15:28

dregad

Details Diff
Remove php_version_at_least() API function

Standard version_compare() function was introduced in PHP 4.1, and
should be used instead.

Fixes 0022842
Affected Issues
0022842
mod - core.php Diff File
mod - core/php_api.php Diff File