View Issue Details

IDProjectCategoryView StatusLast Update
0022635mantisbttime trackingpublic2019-10-27 17:31
Reportervboctor Assigned Tovboctor  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version2.2.2 
Target Version2.4.0Fixed in Version2.4.0 
Summary0022635: Empty notes with time tracking show as empty notes for users that can't view time tracking
Description

The note is valid since it has time tracking information, but for users who don't have access to view time tracking information, the note is visible but it is completely empty.

Such notes should be hidden.

TagsNo tags attached.

Relationships

related to 0026294 closedcproensa Attachments without note text are not displayed 

Activities

Related Changesets

MantisBT: master 1ed44a96

2017-03-31 22:31:14

vboctor

Details Diff
Don’t show completely empty notes

For time tracking notes with no text, if user doesn’t have access
to time tracking information, then an empty note was displayed.
This fix hides the note in such case.

Fixes 0022635
Affected Issues
0022635
mod - core/bugnote_api.php Diff File