View Issue Details

IDProjectCategoryView StatusLast Update
0022363mantisbtrelationshipspublic2017-02-26 21:17
Reportervboctor Assigned Tovboctor  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version2.1.0 
Target Version2.2.0Fixed in Version2.2.0 
Summary0022363: Setting a duplicate id should update relationship with target issue if already exists
Description

At the moment, an error is prompted rather than updating the relationship type to duplicate of. For example, 'related' can become 'duplicate of'.

TagsNo tags attached.

Activities

Related Changesets

MantisBT: master 1516e6e9

2017-02-11 21:23:17

vboctor

Details Diff
Duplicate id updates relationship if exists

If a relationship exists between issue being updated with a duplicate id, and the duplicate issue,
update it to reflect duplicate relationship type rather than erroring out.

Fixes 0022363
Affected Issues
0022363
mod - bug_update.php Diff File
mod - core/constant_inc.php Diff File
mod - lang/strings_english.txt Diff File