View Issue Details

IDProjectCategoryView StatusLast Update
0022245mantisbtuipublic2017-10-08 23:52
Reporterhans peter Assigned Toatrol  
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionfixed 
Product Version2.0.0 
Target Version2.7.0Fixed in Version2.7.0 
Summary0022245: Collapsed menu entry no clickable in complete visible area
Description

when the left main menu is collapsed and the mouse hovers over an entry, the entry is expanded and i can activate the link. but not on the complete area of the expanded entry.
there is a small rectangular part, which is not selectable. this was a bit annoying, as i thought the menu is not working all the time. until i discovered this small not selectable area in the menu entry.

i think the complete menu entry should be selectable, as this is the visual part, the "button", to activate.

i've made some screenshots, see the attached [img]no.link.png[/img].
there you can see the mouse changing the cursor when reaching the not selectable area inside the menu entry.

Steps To Reproduce

collapse menu,
hover over entries,
try to activate the link over every part of the visible menu entry.

Additional Information

behaviour is same on windows and ubuntu, with firefox and iexplore.

TagsNo tags attached.

Activities

hans peter

hans peter

2017-01-25 02:30

reporter  

no.link.png (12,290 bytes)   
no.link.png (12,290 bytes)   
dregad

dregad

2017-01-25 04:40

developer   ~0055314

I think this is an issue with the Ace bootstrap template, their demo shows the same behavior. Maybe @syncguru can bring some expertise here.

dregad

dregad

2017-02-07 06:02

developer   ~0055525

I find this increasingly annoying as I now work with the sidebar collapsed most of the time.

cproensa

cproensa

2017-09-11 13:12

developer   ~0057683

This triangle for hover menus could be removed without much impact.
See attached image

Selección_253.png (30,688 bytes)   
Selección_253.png (30,688 bytes)   
hans peter

hans peter

2017-09-12 02:47

reporter   ~0057688

will this make the whole area clickable/selectable via mouse?

cproensa

cproensa

2017-09-24 21:07

developer   ~0057804

PR https://github.com/mantisbt/mantisbt/pull/1194

atrol

atrol

2017-09-26 04:12

developer   ~0057816

One more PR https://github.com/mantisbt/mantisbt/pull/1196

hans peter

hans peter

2017-09-27 04:44

reporter   ~0057822

patch from 0022245:0057816 works for me on windows 7, with firefox and iexplore.

Related Changesets

MantisBT: master 5a883c3f

2017-09-26 07:23:31

atrol

Details Diff
Make hover arrows clickable on collapsed sidebar menu

Fixes 0022245
Affected Issues
0022245
mod - css/ace-mantis.css Diff File