View Issue Details

IDProjectCategoryView StatusLast Update
0022209mantisbtbugtrackerpublic2017-07-13 14:33
ReporterHaplo Assigned Toatrol  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version2.0.0 
Fixed in Version2.1.0 
Summary0022209: Adding a custom field to a project makes the filter for this project unusable
Description

I've added a custom field to a Project.
When that is done, the filter page for that Project doesn't work anymore: Bad Request

Steps To Reproduce
  • Add a custom field
  • Add this field to a Project
  • Go to the overview page
  • Switch to the Project
  • Try to change a filter -> Message: Bad Request
Additional Information

I'm running it on an IIS / MS-SQL System, but the problem was also on a 1.3.0 Apache / MySql System.

TagsNo tags attached.

Activities

Haplo

Haplo

2017-01-16 04:25

reporter  

atrol

atrol

2017-01-24 16:13

developer   ~0055299

Haplo,

I was not able to reproduce your problem with a fresh install of the latest stable MantisBT release (1.3.5 and 2.0.0 at the moment).

but the problem was also on a 1.3.0 Apache / MySql System

Are you able to reproduce it in the same environment with version 1.3.5?

If so, could you provide even more detailed step-by-step instructions to reproduce the issue; the following additional information may also be useful:

  • Exact version of PHP, Database, Web server, Browser and Operating System
  • Relevant customizations (e.g. changes in config_inc.php, etc)
  • Installed plugins or custom functions ?
  • Was the MantisBT source code modified in any way ?
Haplo

Haplo

2017-01-26 06:40

reporter  

MantisBT_1_selection.png (86,430 bytes)   
MantisBT_1_selection.png (86,430 bytes)   
MantisBT_2_result.png (1,389 bytes)   
MantisBT_2_result.png (1,389 bytes)   
MantisBT_132_Version.png (9,910 bytes)   
MantisBT_132_Version.png (9,910 bytes)   
Haplo

Haplo

2017-01-26 06:46

reporter   ~0055335

After a long search I've finally could reproduce it in my old 1.3.2 test Installation.

  • You need to select the project where the custom field is entered ( I've named it TaskList with the field type Textarea)
  • Select the assigned to -> None
  • Click on Projects -> Error bad request

In the new 2.0.0 Version it is not that specialized. There I can get the error just by adding the tag to the Project and then trying to search..

Version infos:
Mantis 1.3.2
Apache 2.4.17 (WAMP)
MySQL 5.7.9
PHP 5.6.15

Mantis 2.0.0
IIS 8.5.9600
PHP 7.0.9
MS SQL 2016 SP1

Haplo

Haplo

2017-02-08 02:23

reporter   ~0055571

Just for your info:
This isssue seems to be fixed in 2.1.0 :)

atrol

atrol

2017-02-08 02:34

developer   ~0055573

seems to be fixed in 2.1.0 :)

Thanks for the information.
There was a major rewrite of filter functionality in 2.1.0 which seems to have fixed this issue.