View Issue Details

IDProjectCategoryView StatusLast Update
0022031mantisbtrsspublic2017-01-30 09:48
Reportercproensa Assigned Tocproensa  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version1.3.4 
Target Version1.3.5Fixed in Version1.3.5 
Summary0022031: RSS throws a system notice
Description

When using any RSS link

SYSTEM NOTICE: 'Only variables should be passed by reference' in '/...../library/rssbuilder/class.RSSBuilder.inc.php' line 52

TagsNo tags attached.

Relationships

related to 0020372 closeddregad Inline error reports should not mess up non-HTML output 

Activities

cproensa

cproensa

2016-12-11 10:54

developer   ~0054727

Last edited: 2016-12-11 10:55

I have opted for disabling inline error for RSS

Some warnings may be issued due to php strict settings and/or newer versions, as this library is quite old.

https://github.com/mantisbt/mantisbt/pull/975

dregad

dregad

2017-01-30 09:48

developer   ~0055396

Commit MantisBT master 078444f4 message had a typo in referenced issue ID, it should have been Fixes 0022131

Related Changesets

MantisBT: master-1.3.x e992a0a7

2016-12-11 10:52:24

cproensa


Committer: vboctor Details Diff
Prevent inline error in RSS output

Disable inline error reporting to not mess with RSS output.

Fixes: 0022031
Affected Issues
0022031
mod - issues_rss.php Diff File