View Issue Details

IDProjectCategoryView StatusLast Update
0021925mantisbtuipublic2016-12-30 15:54
Reportermcmo Assigned Todregad  
PrioritynormalSeveritytextReproducibilityalways
Status closedResolutionfixed 
Product Version2.0.0-rc.1 
Target Version2.0.0Fixed in Version2.0.0 
Summary0021925: Incorrect text for the remove file button in the file upload dropzone
Description

In MantisBT 2.0.0 Beta 3, after selecting a file to upload a red button appears with the label "Remove file"
In MantisBT 2.0.0 RC1, the label is "undefined"

Tagsmodern-ui

Relationships

related to 0021651 closedsyncguru Dropzone has inline scripts in View Issue page 

Activities

mcmo

mcmo

2016-11-16 11:01

reporter  

mcmo

mcmo

2016-11-16 11:02

reporter  

dregad

dregad

2016-12-01 10:50

developer   ~0054654

@syncguru can you please look into this ?

badfiles

badfiles

2016-12-02 09:41

reporter   ~0054664

I have commented the PR https://github.com/mantisbt/mantisbt/pull/931
after it was merged.
That one breaks dz.

vkall

vkall

2016-12-05 05:48

reporter   ~0054674

I think the problem is here

https://github.com/mantisbt/mantisbt/blob/master/js/common.js#L494

The $(this) doesn't refer to the upload form, which means the data attributes are undefined.

I changed $(this) to $('.dropzone-form') and it started working.

dregad

dregad

2016-12-05 09:27

developer   ~0054679

Last edited: 2016-12-05 09:30

This issue is a regression introduced by 0021651.

@vkall I reached the same conclusion. See proposed fix

PR https://github.com/mantisbt/mantisbt/pull/972

Related Changesets

MantisBT: master ef248e95

2016-12-11 23:14:05

dregad


Committer: vboctor Details Diff
Fix dropzone localization

Fixes 0021925
Affected Issues
0021925
mod - js/common.js Diff File