View Issue Details

IDProjectCategoryView StatusLast Update
0021807mantisbtuipublic2017-09-03 18:41
Reportermcmo Assigned Tocommunity  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version2.0.0-beta.1 
Target Version2.6.0Fixed in Version2.6.0 
Summary0021807: The required fields are not explicitly visible when updating, resolving or closing an issue
Description

The red asterisks are not displayed when updating, resolving or closing an issue.
They are displayed when creating an issue.
This is annoying as if you have several fields that are required on closing, then you may have to try several times before you can effectively submit the form.

Steps To Reproduce

create a custom field
make it mandatory on reporting, updating. resolving and closing an issue
create an issue
update it: the red asterisk does not appear for the custom field
_ do not enter a value in the custom field and submit the change.
for each field that is required and not filled in, you would get an application error #11 message to enter that value

Additional Information

I have checked the code and the <SPAN> elements that previously contained that asterisk are missing.
For instance, in bug_update_page.php, in 1.3.0 RC1
line 685 '<span class="required">*</span>
that disappeared in 1.3.2 and 2.0.0b3

Tagsmodern-ui

Relationships

related to 0021694 assignedsyncguru inconsistent presentation of required fields 
has duplicate 0022824 closedatrol Required markers are missing on change status page. 
related to 0023213 new Required standard fields are not marked as required when updating issues 

Activities

mcmo

mcmo

2016-10-19 03:48

reporter  

mcmo

mcmo

2016-10-19 03:49

reporter  

mcmo

mcmo

2016-10-19 03:50

reporter   ~0054265

Can someone remove the 2nd attachment, please?
It's useless.
Sorry for that mistake.

atrol

atrol

2016-10-19 04:16

developer   ~0054266

Seems I removed the wrong one as I didn't notice that dregad did already remove another attachment.

dregad

dregad

2016-10-19 04:33

developer   ~0054267

In 1.3.x branch, everything works fine as far as I can tell. I see the red * before required custom fields in bug report and update pages, as well as on change status pages.

For the record, the <span class="required">*</span> is no longer needed, because we rely on CSS to display the asterisk [1]

That being said, I confirm that this is broken in 2.0 (the .required:before class is gone). It also appears that in at least some cases (e.g. bug_report_page.php), the code reverts to using spans to display the asterisk.

[1] https://github.com/mantisbt/mantisbt/blob/master-1.3.x/css/default.css#L536

mcmo

mcmo

2016-10-19 04:40

reporter  

mcmo

mcmo

2016-10-19 04:57

reporter   ~0054269

If the "<span class="required">*</span>" is no longer needed, then I would suggest that you apply the CSS class also to the "normal" fields like "Summary" when reporting an issue.
that would solve the issue 0021694

mcmo

mcmo

2016-10-19 05:10

reporter   ~0054270

I changed /css/default.css by adding the missing lines, and that solved the issue when editing the issue.
However that does not work when changing the status.

mcmo

mcmo

2016-10-19 05:49

reporter   ~0054271

Last edited: 2017-03-29 08:34

That works now when resolving or closing an issue after changing bug_change_status_page.php

--- a/&lt;html>bug_change_status_page.php (<b>Yesterday 12:41:20</b>)&lt;/html>
+++ b/&lt;html><b>Current File</b>&lt;/html>
@@ -291,6 +291,7 @@
 ?>
    &lt;tr>
        &lt;th class=&quot;category&quot;>
+                    &lt;label &lt;?php echo $t_class_required ?>>&lt;/label>
            &lt;?php echo lang_get_defaulted( $t_def['name'] ) ?>
        &lt;/th>
        &lt;td>

thanks for your help

EDIT (dregad): fixed markdown

fman

fman

2017-03-29 08:31

reporter   ~0056262

My 5 cents using info I've found in this ticket

just added following lines to default.css on version 2.1.0 and Custom Fields have * when editing issue

/ from 1.3.7 /
div.form-container fieldset label.required:before,
th label.required:before,
td label.required:before {
font-size: 8pt;
content: '* ';
color: red;
}

Related Changesets

MantisBT: master 29cc2eb3

2017-04-29 21:29:54

badfiles


Committer: vboctor Details Diff
Fix required custom fields marker

- Fix required custom fields marker on bug_change_status_page.php
- Remove unused variables

Fixes 0021807
Affected Issues
0021807
mod - bug_change_status_page.php Diff File
mod - bug_report_page.php Diff File