View Issue Details

IDProjectCategoryView StatusLast Update
0021722mantisbtattachmentspublic2016-10-30 23:22
Reporterdregad Assigned Todregad  
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionfixed 
Product Version2.0.0-beta.1 
Target Version2.0.0-rc.1Fixed in Version2.0.0-rc.1 
Summary0021722: Issues with '+' button to view attachments inline
Description

I see a couple minor issues with the +/- collapse button used to display inline attachments

  1. on hover, the mouse cursor is set to 'text' instead of 'pointer'
  2. The fact that it's so small, and to the right of the (much bigger) delete button (if available) makes it not very visible

1 is an easy fix, but I'm not sure what the best approach for 2 would be... use the same style as the Delete button, move the existing button to the left, use another icon (like the chevrons used for other collapse sections), etc. Ideas welcome.

Tagsmodern-ui

Relationships

related to 0021727 closedvboctor Show attachments inline with notes 

Activities

dregad

dregad

2016-09-27 11:27

developer  

attachment_expand.png (3,545 bytes)   
attachment_expand.png (3,545 bytes)   
dregad

dregad

2016-09-29 05:16

developer   ~0054093

CSS fix for mouse cursor issue (point 1 above): https://github.com/dregad/mantisbt/tree/f20-21722-attach-collapse

Waiting for feedback before implementing anything for point 2.

vboctor

vboctor

2016-09-29 11:08

manager   ~0054095

I can't repro 1 in modern ui. I see the mouse pointer.

The big delete button may go away as part of 0021727

dregad

dregad

2016-09-30 02:50

developer   ~0054098

I can't repro 1 in modern ui. I see the mouse pointer.

This is consistently reproducible (including on this very instance), from multiple client platforms and browsers. The screenshot I attached may have mislead you, as the mouse cursor looks faded on it (not sure why). It is not a problem of the pointer not being visible, but the fact that it looks like an I beam instead of a pointing hand.

syncguru

syncguru

2016-10-01 22:43

developer   ~0054105

For (2): I think the delete button should be changed to 'garbage can' icon. The preview icon can remain the same (but larger in size).

dregad

dregad

2016-10-05 03:17

developer   ~0054132

(2) being implemented as part of 0021727 (see PR https://github.com/mantisbt/mantisbt/pull/909), this issue's scope is reduced to only cover fixing the mouse cursor for the [+] button.

Related Changesets

MantisBT: master d4c1353d

2016-09-27 18:55:26

dregad

Details Diff
Set cursor to pointer for collapse-link

Fixes 0021722
Affected Issues
0021722
mod - css/default.css Diff File