View Issue Details

IDProjectCategoryView StatusLast Update
0012967mantisbtreportspublic2016-07-19 04:19
Reportercor3huis Assigned Tovboctor  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.2.5 
Target Version2.0.0-beta.1Fixed in Version2.0.0-beta.1 
Summary0012967: Category jpGraph not displayed
Description

Category jpGraph not displayed and gives error Unknown Font Family Specification

Steps To Reproduce

1) Log in with a user which has right to view summary, e.g. Manager
2) Choose a project with some issues
3) Choose subproject
4) Click on [ Summary ]
5) Then click [ Advanced Summary ]

Then the part of

http://www.example.com/mantisbt/plugin.php?page=MantisGraph/summary_graph_bycategory.php&width=750

gives the error "Unknown Font Family Specification"

Additional Information

Note that all other graphs are displaying OK

TagsNo tags attached.

Relationships

related to 0012825 closedvboctor Modern graphs using javascript graphing library 

Activities

cor3huis

cor3huis

2011-05-01 11:15

reporter  

cor3huis

cor3huis

2011-05-01 11:22

reporter   ~0028727

Last edited: 2011-05-01 11:36

The buggy part is probably in summary_graph_bycategory.php of the MantisGraph

cor3huis

cor3huis

2011-05-01 11:42

reporter   ~0028728

Last edited: 2011-05-01 12:05

It happen if there is (No category) assignend to issues.

As soon as one assigns a Category the error does not show up.

then if all categories are deleted from this project the error shows up again.

Thus a specific filter must be made that if no category is available also do not display something in the graph. The issue is this not a Font issue, only an issue that there is no category data.

cor3huis

cor3huis

2011-05-01 12:05

reporter   ~0028729

Last edited: 2011-05-01 12:22

A solution is to change summary_graph_bycategory.php from

...
graph_bar( $t_metrics, lang_get( 'by_category' ), $f_width, $f_width * $t_ar );
...

TO

...

if (isset($t_metrics) {
graph_bar( $t_metrics, lang_get( 'by_category' ), $f_width, $f_width * $t_ar );
}